Skip to main content.

sáb, 21 de abril, 2007

Siempre es util tener una lista de los comando de un router, hice este resumen de algunos comando s. Si hay gente que sepaalgunos puede agregarlos para ayuda de todos.

Router>

Router>enable
Router#

Router# configure terminal
Router(config)#

Historia de commandos
#show history

Reloj
Router#clock set 19:50:00 14 july 2003

Cambiar nombre del router
Router(config)#hostname Expo
Expo(config)#

Configurar una Interfaz
DCE
Expo(config)#interface serial 0/0
Expo(config-if)# ip address IP MASK
Expo(config-if)#bandwidth 56
Expo(config-if)#clock rate 64000
Expo(config-if)#no shutdown
Expo(config-if)#end

DTE
Expo(config)#interface serial 0/0
Expo(config-if)# ip address IP MASK
Expo(config-if)#bandwidth 56
Expo(config-if)#no shutdown
Expo(config-if)#end



Expo(config)#interface fastethernet 0/0
Expo(config-if)#ip address IP MASK
Expo(config-if)#no shutdown
Expo(config)#end

Copy
Router# copy flash tftp
Router#copy running-config tftp
Router#copy tftp running-config

Configuración de Rutas Estáticas

Expo(config)#ip route RED MASK GATEWAY

Poner Password al Router
Expo(config)#line console 0
Expo(config-line)#password *******
Expo(config-line)#login

Expo(config)#line vty 0 4
Expo(config-line)#password *******
Expo(config-line)#login

Expo(config)#enable password ******

Encriptar Password
Expo(config)#service password-encription
Expo(config)#enable secret *******

Hostname
Expo(config)#ip host NOMBRE IP

Uso de protocolo cdp
Expo(config)#cdp run
Expo(config)#no cdp run
Expo#show cdp neighbors
Expo#show cdp neighbors detail

Booteo del router
Expo(config)#boot system flash IOS_filename
Expo(config)#boot system tftp IOS_filename tftp_addres
Expo(config)#boot system rom

Copiar el IOS desde un Tftp desde la ROMmon
Rommon1>set (llevar los valores pedidos del servidor tftp)
Rommon2>tftpdnlp

Archivos de configuración
Expo(config)#config-register 0x2142 (para no cargar archivos de configuración de la nvram)
Expo(config)#config-register 0x2102 (para cargar archivos de configuración de la nvram)

0xnnn0 = usar el modo de monitoreo rom
0xnnn1= carga la primera imagen de la flash
De 0xnnn2 a 0xnnnf = carga el archivo de la nvram

Configuración de las Rutas por defecto
Expo(config)#ip route 0.0.0.0 0.0.0.0 [direcciòn del siguiente salto] [interface de salidad]

Enrutamiento RIP
Expo(config)#router rip
Expo(config-router)#network direccion de la RED(red conectada al router)

Debug ip rip


Enurutamiento IGRP
Expo(config)#router igrp 101(sistema autónomo)
Expo(config)#network direccion de la RED(red conectada al router)



Recuperar un router con password
Arrancar el router con el hyperterminal conectado.
Antes de que pase 60 segundos mandar una secuencia BREAK al
puerto serie, desde el hyperterminal se corresponde con las teclas Crtl+Pausa.
Se entrara en modo ROMMON.
El promtp será: rommon 1>
Teclear el comando confreg 0x2142
El promt será ahora rommon 2>
Teclear reset. El router se reinicia.
Después de arrancar saltarse las preguntas que hace el router para la configuración inicial con Ctrl+C .
Teclear enable, (ahora no hay passwords).
Y desde el promt en # teclear:
write erase
reload para reiniciar de nuevo.

Activar interfaz WEB
ip http Server

Recuperación Del Rommon

se puede entrar ctrl.-break rommon

rommon1> IP_ADDRESS = dirección de la interfaz LAN
rommon2>IP_SUBNET_MASK= Mascara de subred para la interfaz LAN
rommon3>DEFAULT_GATEWAY= gateway predeterminado para la interfaz LAN
rommon4>TFTP_SERVER= direccion ip del server tftp
rommon5>TFTP_FILE= Nombre de archivo del software cisco

rommon6> set
IP_ADDRESS = dirección de la interfaz LAN
NET_MASK= Mascara de subred para la interfaz LAN
DEFAULT_GATEWAY= gateway predeterminado para la interfaz LAN
TFTP_SERVER= direccion ip del server tftp
TFTP_FILE= Nombre de archivo del software cisco

Rommon7>tftpdnld

Rommon8>dir flash: (para verificar el archivo)

Rommon9>reset

Copiar el IOS desde un server tftp

router# copy tftp flash
pregunta sobre la ip? Ip address del Server tftp
nombre del archivo ios? Nombre del archivo

Mensaje del dia MOTD
Configure Terminal
banner motd # Escriba aquí el mensaje del día #.
copy running-config startup-config

Access list

Estándar
Router#Access-list #(access-list) ip wildmask

interface
Router(config-if)#ip access-group 1 in
Router(config-if)#ip access-group 1 out

Access-list extendida

access-list [100-199] [permit/deny][protocolo] [ip origen] [ip destino] [tipo de servicio]
ip access-group [100-199] [in/out]

ejm. Denegar un host
access-list 1 deny 192.168.500.5 0.0.0.0
access-list 1 permit 0.0.0.0 255.255.255.255
interface>>>>>>>ip access-group 1 out

Access-list nombrada
Router(config)#Ip access-list [standard/extended] [nombre]

Router(config-std-nacl)#[permit/deny] [ip origen]

Router(config-ext-nacl)#[permit/deny] [protocolo][ip origen] [ip destino] [tipo de servicio]

Ejm. Denegar el telnet a una subred
Access-list 101 deny tcp 172.16.4.0 0.0.0.255 any eq 23
Access-list 101 permit ip any any

Interface>> access-group 101 out


Acces-list en terminales virtuales
Router(config)#Ip access-list 10 permit 192.168.100.15
Router(config)#line vty 0 4
Router(config-line)#access-class 10 in



Visualizadores
Show access-list (#) Muetsra todas la access list o una em particular
Show ip access-list Muetsra la acl ip
Show ip interface muestra los puertos que tienen activada acl
Show running-config muestra las listas de acceso y donde estan aplicadas


Puertos
ftp 21 tcp
telnet 23 tcp
smtp 25 tcp
dns 53 udp
dhcp 67 udp
tftp 69 udp
http 80 tcp
pop3 110
irc 164
snmp 161


vizualisadores
show flash
show version
Show interfaces
Show controllers serial (muestra la información sobre la sincronía)
Show clock
Show hosts
Show users
Show history
Show flash
Show version
Show startup-configuration
Show running-configuration
Show cdp neighbors
Show cdp interface
Show ip protocols

Administracion
Router#Traceroute [ip de destino]

Descripcion de una interface
Router(config)#interface xxxxx
Router(config-if)#description xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Host
Router(config)# ip host [nombre] [direccion ip]

Telnet
router>telnet denx
denx>exit
denx>ctrl shift 6 x
router>

Horizontre divido
ip split-horizon
no ip split-horizon


Poison Reverse(envenenamiento de rutas)
IGRP
router(config)# router igrp 109
router(config-router)# default-metric 1000 100 250 100 1500
(bandwidth = 1000 (1Mbps), delay = 100 (1 sec), reliability = 250 (near 100% reliable), loading = 100 (100% bandwidth), and MTU = 1500 (bytes). )

RIP (poison reverse tiene precedencia sobre split horizon, si también está habilitado split horizon)
El comando es
set rip poisonreverse enable


leer más en www.conetta2.com Etiquetas :

item rate
Total de Votos: 127 - Rating: 4.45

Vota por este artículo:


Ingrese su correo electrónico para suscribirse a los comentarios de este artículo:

Ingrese los caracteres de la imagen y presione el botón "Suscribirse":

Comentarios

Excelente Info =D Thx

Publicado por Edeshi el día mié, 02 de mayo, 2007 a las 12:08:36

Excelente iniciativa, quiero poner a su consideración el comando:

Router(config)#no ip domain lookup

es util para evitar demoras cuando el IOS intenta traducir por dns a direccion ip un comando errado o texto no interpretado.
Saludos.

Publicado por Manuel Anaya Estrada el día mar, 04 de septiembre, 2007 a las 23:52:14

ME ENCANTA TU BLOG!!...

ESTA MUY BIEN!!

ATTE_CRISTY.

Publicado por CRISTELEMATICA el día lun, 21 de abril, 2008 a las 10:36:59

me encanta todo lo que tiene que ver con router si me puedes enviar mas

porfa : melboy.zk@gmail.com
macros_zk@hotmail.com

Publicado por edgra el día jue, 22 de mayo, 2008 a las 08:45:22

eso esta muy bien

Publicado por peter el día jue, 05 de junio, 2008 a las 16:01:37

ESTA BIEN LA INFORMACION, DESEARIA QUE ME ENVIES A MI CORREO MAS INFORMACION SOBRE LOS ROUTER.

HASTA PRONTO.

Publicado por Jose Angel Felix el día jue, 10 de julio, 2008 a las 07:57:30

hola,

sabes que tengo un router cisco 800 pero no entiendo bien como sacar la contraseña del router ya que inicia y todo pero no puedo hacer nada por la contraseña que me pide...
ojala me puedas ayudar

saludos
muy buena ayuda con los comandos...

Publicado por Pablo Espinoza el día sáb, 19 de julio, 2008 a las 23:15:57

Excelente Resumen de Comandos, nos recuerda cosas que con el tiempo se nos van pasando.

Publicado por Manuel Ramon Anaya Estrada el día dom, 20 de julio, 2008 a las 09:18:01

Estoy empezando en esto de la seguridad en redes,tus comandos me aclaran bastante las cosas.gracias

Publicado por miguel angel el día jue, 11 de septiembre, 2008 a las 09:50:51

Gran página, mira ... yo resetee el router...le hice de todo, me da ya ip, le puse la puerta de enlace, pero a la hora de entrar al router x la puerte de enlace...me pide en el internet explorer usuario y contraseña...i yo el usuario como ke no me lo se...y la contraseña no se si es la misma ke la ke puse x hyperterminal con "enable secret "password"" asi ke...exame una mano y si lees esto..contesta a mi duda a este correo
pepehostias@gmail.com
gracias!!!

Publicado por Pepe largo el día lun, 15 de septiembre, 2008 a las 04:56:27

Alguien puede ayudarme a realizar un ejercicio que no puedo ya voy una semana y no me sale por ningun lado..

el ej. se encuentra publicado en
webmail.espoch.edu.ec
la cuenta es:

usuario: cisco@espoch.edu.ec
password: cisco2005
ayudenme porfavor es urgente:

Publicado por Henry Javier el día sáb, 01 de noviembre, 2008 a las 19:20:46

Show ip protocol
para verificarlos

Publicado por Fredaso el día vie, 03 de abril, 2009 a las 11:01:58

alguien me puede ayudar a decifrar que script usar para reiniciar el modem para que cambie la ip de un modem huawei mt882 para usarlo en jdownloader

desde ya muchas gracias
esto script estoy usando pero no funciona nose si esta mal

[[[HSRC]]]
[[[STEP]]]
[[[REQUEST]]]
AUTH /? HTTP/1.1
Host: %%%routerip%%%
Authorization: Basic %%%basicauth%%%
[[[/REQUEST]]]
[[[/STEP]]]
[[[STEP]]]
[[[REQUEST]]]
GET /? HTTP/1.1
Host: %%%routerip%%%
[[[/REQUEST]]]
[[[/STEP]]]
[[[STEP]]]
[[[REQUEST]]]
GET /MainPage?id=45 HTTP/1.1
Host: %%%routerip%%%
[[[/REQUEST]]]
[[[/STEP]]]
[[[STEP]]]
[[[REQUEST]]]
GET /hag/pages/menu.htm?menu=0 HTTP/1.1
Host: %%%routerip%%%
[[[/REQUEST]]]
[[[/STEP]]]
[[[STEP]]]
[[[REQUEST]]]
GET /data?cli=10&dat=nsa&ver=megaupload-megauploadtoolbar&uid=20080420235442&url=http%3A%2F%2F192.168.1.2%2F HTTP/1.1
Host: %%%routerip%%%
[[[/REQUEST]]]
[[[/STEP]]]
[[[STEP]]]
[[[REQUEST]]]
GET /MainPage?id=6 HTTP/1.1
Host: %%%routerip%%%
[[[/REQUEST]]]
[[[/STEP]]]
[[[STEP]]]
[[[REQUEST]]]
GET /hag/pages/menu.htm?menu=3 HTTP/1.1
Host: %%%routerip%%%
[[[/REQUEST]]]
[[[/STEP]]]
[[[STEP]]]
[[[REQUEST]]]
GET /data?cli=10&dat=nsa&ver=megaupload-megauploadtoolbar&uid=20080420235442&url=http%3A%2F%2F192.168.1.2%2Fhag%2Fpages%2Fmenu.htm%3Fmenu%3D3 HTTP/1.1
Host: %%%routerip%%%
[[[/REQUEST]]]
[[[/STEP]]]
[[[STEP]]]
[[[REQUEST]]]
GET /MainPage?id=6 HTTP/1.1
Host: %%%routerip%%%
[[[/REQUEST]]]
[[[/STEP]]]
[[[STEP]]]
[[[REQUEST]]]
GET /hag/js/global.gsv? HTTP/1.1
Host: %%%routerip%%%
[[[/REQUEST]]]
[[[/STEP]]]
[[[STEP]]]
[[[REQUEST]]]
GET /data?cli=10&dat=nsa&ver=megaupload-megauploadtoolbar&uid=20080420235442&url=http%3A%2F%2F192.168.1.2%2FMainPage%3Fid%3D6 HTTP/1.1
Host: %%%routerip%%%
[[[/REQUEST]]]
[[[/STEP]]]
[[[STEP]]]
[[[REQUEST]]]
GET /MainPage?id=4 HTTP/1.1
Host: %%%routerip%%%
[[[/REQUEST]]]
[[[/STEP]]]
[[[STEP]]]
[[[REQUEST]]]
GET /data?cli=10&dat=nsa&ver=megaupload-megauploadtoolbar&uid=20080420235442&url=http%3A%2F%2F192.168.1.2%2FMainPage%3Fid%3D4 HTTP/1.1
Host: %%%routerip%%%
[[[/REQUEST]]]
[[[/STEP]]]
[[[STEP]]]
[[[REQUEST]]]
GET /Action?save_reboot=1&reboot_loc=0&id=5 HTTP/1.1
Host: %%%routerip%%%
[[[/REQUEST]]]
[[[/STEP]]]
[[[STEP]]]
[[[REQUEST]]]
GET /data?cli=10&dat=nsa&ver=megaupload-megauploadtoolbar&uid=20080420235442&url=http%3A%2F%2F192.168.1.2%2FAction%3Fsave_reboot%3D1%26reboot_loc%3D0%26id%3D5 HTTP/1.1
Host: %%%routerip%%%
[[[/REQUEST]]]
[[[/STEP]]]
[[[/HSRC]]]

Publicado por cristian el día dom, 12 de abril, 2009 a las 00:38:35

como hago para darles menos ancho de banda a mi red interna gracias

Publicado por rafael el día dom, 26 de abril, 2009 a las 18:32:34

fernando un favor nesecito los comandos router interfases usadas el uso de hiperterminal

Publicado por fernando el día lun, 18 de mayo, 2009 a las 19:39:24

¿Cómo podría realizar un testeo de las BRI?

con algo más que un show.

En mi caso la conexión es via RDSI. Y de vez en cuando tengo problemas de lentitud tan sólo me gustaría poder demostrar que no es cosa de mi línea si no del cliente final.

Gracias anticipadas y felicidades por una página de lo más útil

Publicado por Mareta el día mar, 19 de mayo, 2009 a las 05:52:03

Gracias Miguel!

Publicado por El compadre del Miguel el día dom, 06 de septiembre, 2009 a las 16:54:08

bueno tio, excelente de igual manera, muy util estos comandos, q bueno q son los blog, a veces te sacan de un gran apuro, hoy no fue asi, estoy estudiando todo este fascinante mundo, tambien quiero aportar el comando:
Router(config)#line console 0
Router(config-line)#logging synchronous

y es útil para evitar que salten líneas de aviso cuando bajas o subes una sub-interface por ejemplo.

Publicado por Jose Rojo Cansino el día dom, 06 de septiembre, 2009 a las 16:55:44

Muy buena pagina estimado

Publicado por Jose Salvador el día mar, 03 de noviembre, 2009 a las 17:31:17

estimado Miguel te sacaste un 10 con tu info. me gustaria si es posible me mandaras mas info de configuracion de routers y switch pues soy novato y tu blog me sirvio de muchisimo te paso mi correo
gracias.

Publicado por novato el día mié, 24 de febrero, 2010 a las 12:24:24

buenas al que haya escrito este bolg.
pero soy tecnico superior de CISCO SYSTEMS,con el CCIE. y he econtrado un error en cuanto a los comandos..
Al cambiar las IOS desde rommon no es el comando como el que has puesto:
<<Copiar el IOS desde un Tftp desde la ROMmon
Rommon1>set (llevar los valores pedidos del servidor tftp)
Rommon2>tftpdnlP<-----

LA -P- ES UN ERROR YA QUE EL EQUIPO NO TE COGE EL COMANDO..SI NO QUE EL EQUIPO TE LO COGE TERMINADO CON LA LETRA -D- de download..

os escribo para que os sirva major...ya que el que ha escrito estos comando no esta del todo puesto en el tema
gracias.

Publicado por franCISCO el día mié, 21 de abril, 2010 a las 02:46:29

muchas gracias miguel...me sirvio mucho
saludos!!

Publicado por mariano el día lun, 17 de mayo, 2010 a las 16:35:59

Ola miguel me sirvi de mucho tu informacio me gustaria saber mas de router si tienës me invias. gracias.
e=mail: nmartin_1296@hotmail.com

Publicado por noesio el día mar, 25 de mayo, 2010 a las 09:54:13

holas tengo un rauter cisco 800
quiero saber si tengo que entrar por DOS u otro programa en especial para reiniciarlo y configurarlo y si alguien sabe ya como hacerlo me puede dar su correo electronico pa que me ayude en eso por favor... muchisimas gracias de antemano
marcoz29_05@hotmail.com

Publicado por marcoz el día lun, 11 de abril, 2011 a las 14:39:45

hola como puedo levantar un servidor dhcp con comandeo mi correo es xnova360@hotmail.com te lo agradeceria mucho

Publicado por Xnova el día mié, 18 de mayo, 2011 a las 22:04:42

Tengo un router cisco 1700 el cual se me olvido la password y necesito entrar en modo Rommon, pero al reiniciarlo y mantengo pulsado la teclas ctrl + pausa, no las toma y carga el IOS sin ninguna interrupcion, necesito ayuda para saber que pasa, utilizo Win7 y de terminal ocupo Secure CRT. De antemano muchas gracias.

Publicado por Juan Carlos el día dom, 09 de octubre, 2011 a las 15:02:06

hola miguel muchas gracias por tu trabajo soy nuevo en esto,necesito un poco de ayuda porfa,tengo un router cisco 1800 quiero ingresar al modo rommon para un recovery password y no me responden las teclas control-fn- pausa- de mi portatil entre por el teclado virtual y tampoco, esa es miinquietud gracias

Publicado por edmudo el día lun, 04 de junio, 2012 a las 09:45:02

Hi there.Hi there to Each. I'm definitely glad I discovered your blog. I am working to get up to date. I've marked this for future useful resource and anticipate to be involved in future conversations. Many thanks.

Publicado por Enoch el día sáb, 06 de abril, 2013 a las 17:34:01

Hola amigo, tal vez tengas los comandos o la configuracion para bloquear los https (redes sociales)en un cisco serie 800. Gracias.

Publicado por WILLIE el día jue, 27 de febrero, 2014 a las 01:53:25

Añadir Comentario

:

: (obligatorio)



(obligatorio)

Su comentario deberá ser aprobado antes de ser publicado. Gracias!